AddrView v1.01
Copyright (c) 2004 Nir Sofer

Description

AddrView allows you to parse HTML pages and extract most URL addresses stored in them. AddrView extracts URLs of images (<img> tag), links to other files (<a> tag), CSS files, frames, Flash files, and more.
You can save the extracted addresses list to text, HTML or XML files, or add these addresses to your Favorities.

Versions History

  • Version 1.01: Added new option to save and copy to clipbard a plain text that only contains the URLs list.
  • Version 1.00: First Release.

Known Limitations

  • AddrView cannot extract URL addresses from JavaScript or VBScript code.
  • When you open an HTML file from your local drive, AddrView won't be able to display the absolute URLs of relative addresses, unless the base URL of this HTML file is specified in <base> tag.

System Requirement

This utility works on any version of Windows operating system with Internet Explorer version 4.00 or greater.

Using AddrView

AddrView is provided as standalone executable, so it doesn't require any installation process or additional DLLs. Just copy the executable (addrview.exe) to any folder you like, and run it.
After running it, you can select one of the following options from the menu:
  • Open URL Address: Downloads the HTML page from the HTTP address that you type, and displays all addresses that it finds in this page.
  • Open HTML File: Opens HTML page from local file on your drive, and displays all addresses that it finds in this page.

You can select one or more URL addresses, and then save them into text, HTML, or XML file, or add them to your Favorities list by using 'Create Links To Selected URLs' option.

License

This utility is released as freeware for personal and non-commercial use. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com