AsterWin IE v1.03
Copyright © 2002 - 2004 Nir Sofer

Web Site: www.nirsoft.net

Description

When you login into a web site with user name and password, you sometimes have the option to store the password in your computer. If you choose to save the password, in the next time that we'll visit this site, the password field will be automatically filled with your password, but you won't be able to view it, because the password-box shows the password as sequence of asterisks (****).
This utility reveals the passwords stored behind the asterisks in the web pages of Internet Explorer 5.0 and above. You can use it for recovering a lost web site password, if it's stored on your computer.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this. If you distribute this utility, you must include all files in the distribution package including the source code, without any modification !
You are not allowed to combine this utility with a commercial product in any way !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

System Requirements

  • Windows 95/98/ME or Windows NT/2000/XP with Internet Explorer 5.0 or above.
  • VB6 Runtime files.

File List

The AsterWin IE package contains the following files:
Filename | Description
readme.txt | The Readme text file.
asterie.chm | The help file you're reading now !
asterie.exe | The utility executable.
asterie.vbp | Visual Basic project file.
asterie.frm | Visual Basic Form files.
asterie.frx

The Visual Basic form and project files (the files in green color) are required only if want to run this utility from Visual Basic environment.

Installing AsterWin IE

AsterWin IE was written in Visual Basic language and requires the Visual Basic runtime files in order to run properly. this package also includes the source code of this utility.
If Visual Basic (version 5.0 or 6.0) is installed on your computer, you can easily run this utility as executable file or in the Visual Basic environment (by using the source code).

If you don't have Visual Basic installed on your computer, follow the instructions below:

  1. Try to run the executable: asterie.exe .
  2. If the executable is running properly without any error messages about missing files, you can use it without any further installations. If you receive any error message when you try to run this utility, continue to the next instruction.
  3. Download the VB6 runtime files. you can find them in the following web sites:
    • At Microsoft Web site: http://www.microsoft.com/downloads/release.asp?releaseid=28337&area=top&ordinal=23
    • At Simtel.Net Web site: http://www.simtel.net/vbrun.php ,download the "VB6 Runtime Modules".
  4. Install the VB6 Runtime files on your computer.
  5. After the installation is completed, you'll be able run and use the "AsterWin IE" utility.

Using AsterWin IE

In order to recover stored web site password, follow the instructions below:
  1. Open Internet Explorer, and go to the login page of the web site that you want to recover its password.
  2. Type your login name. If the password in stored on your computer, a sequence of asterisks will appear in the password field.
  3. Run the asterie.exe and click the "Show Internet Explorer Passwords" button. The utility will scan all opened Internet Explorer windows, and the password will be revealed after a few seconds.

Known Problems

If you close one of the Internet Explorer windows while this utility is searching for a password, you might get an error message, and the windows scanning will be stopped. In such cases, wait a few seconds and then start the scanning again.

Versions History

Date | Version | Description
01/06/2004 | 1.03 | A little change to make the scanning process a little faster.
09/03/2003 | 1.02 | Fixed bug: "Error 70: Permission Denied" problem.
17/06/2002 | 1.01 | Fixed bug: "Access is denied" error in some Web sites.
02/03/2002 | 1.00 | First Release

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com